Force background image to render unaffected by lighting

The Twilight Render Team shares tips, ideas, helpful hints, and more on using Twilight Render
Post Reply
Ecuadorian
Posts: 1779
Joined: Fri Mar 20, 2009 3:43 pm
OS: Windows 7 Pro 64-bit
SketchUp: 7.1
Location: Guayaquil, Ecuador
Contact:

Force background image to render unaffected by lighting

Post by Ecuadorian » Sat Sep 19, 2009 9:35 pm

Para ver la versión en Español, presione aquí.

Some users don't want to add a background in post-processing but prefer to place it as a plane inside SketchUp. Also, you might want to add images to TVs and computer screens. In all these cases, you might want the inserted image to render exactly as it is, without being affected by the sun/sky/lights in your scene. Here's how.

The following setting works perfectly for Exposure = 1.0, Gamma = 1.0:

1 - Explode your image so it becomes a texture applied on a plane.
2 - In the Twilight material editor, choose Templates > Light Emitter, any of them
3 - Set the Power (W/m2) to 150.
4 - Next to the light bulb, Change Emitter > Normal to Emitter > Fake.
5 - Unmark the "Cast shadow" checkbox.

Your material settings should now look like this:
fake-emitter-150-noshadow.jpg
fake-emitter-150-noshadow.jpg (82.77 KiB) Viewed 10453 times
If you're using a different Exposure value, use this simple formula to calculate the power for your fake emitters:

Power for your fake emitter = 150/exposure²

Examples:
For an exposure value of 0.5, you must set your fake emitters to 150/(0.5)² = 600.
For an exposure value of 1.2, you must set your fake emitters to 150/(1.2)² = 104.167
For an exposure value of 2, you must set your fake emitters to 150/(2)² = 37.5

In all cases, you need to keep a gamma of 1.0 if you want your images to render unaltered.

NOTE: Fake emitters only exist in Presets Easy 01-08. With Easy 09-11 they become real emitters, thus contributing light to your scene.

Feel free to translate this information to other languages and post it to the respective international forum.
Last edited by Ecuadorian on Sat Oct 03, 2009 7:48 pm, edited 1 time in total.

Gareth
Posts: 650
Joined: Thu Sep 03, 2009 2:26 pm
OS: Windows 10
SketchUp: SU8 to SU2019 Pro
Location: Adelaide, South Australia
Contact:

Re: Force an image to render unaffected by lighting

Post by Gareth » Sun Sep 20, 2009 1:34 am

thanks for the handy tip Miguel :!:

Pg09
Posts: 150
Joined: Wed Aug 26, 2009 3:20 pm
Location: Trinidad

Re: Force an image to render unaffected by lighting

Post by Pg09 » Sun Sep 20, 2009 4:49 am

Great stuff like that should be added to the next version of the Manual...
Cheers,

Adam

Ecuadorian
Posts: 1779
Joined: Fri Mar 20, 2009 3:43 pm
OS: Windows 7 Pro 64-bit
SketchUp: 7.1
Location: Guayaquil, Ecuador
Contact:

Re: Force an image to render unaffected by lighting

Post by Ecuadorian » Fri Sep 25, 2009 4:08 pm

As a note, the "no shadows" and "fake" settings do not work when using the Metropolis Light Transport render method (Easy 09 Interior and Easy 10 Interior+), but work well in all other "Easy" modes, including Easy 08 Exterior Daytime. This is because when using MLT all emitters, no matter their setting, become "true" ones, and cast shadows.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests