
Codec
A Codec is used during processing of an animation using a separate video editing program such as Windows Movie Maker, or the free 
and easy-to-use VirtualDub.  Using a Video Editing program one may open a series of .jpg images, just as rendered from Twilight, and 
save them as an .avi video.  Using a Codec allows the program to compress this .avi video resulting in a much smaller file size.

It is important to remember that many codecs require a certain size or image proportion in order to be used.  For example, when using 
the Xvid codec, the Width of the image must be divisible by 4 and the height must be divisible by 2.  Paying special attention to the size of 
the rendered image for animations therefore becomes critical in post-processing.

Color Codes -  RGB, HEX
Twilight will accept common English names for colors,(i.e. [White], [Yellow], [Brown], etc.)  It will accept RGB colors typed in this format: 
[rgb(62, 91, 5)].  It will also use HEX codes in this format [#704E32] when pasted into the color line.  Use of these formats apply for all 
Twilight Dialogs where a Color Code can be used.

Custom Material Templates and Material Libraries
“If I spend time to modify a Twilight Material Template to get something I want, can I save that as a Custom Template?”

Saving the SketchUp model saves the settings. But there is, for the moment, not a way to simply save a template setting for reloading 
later.  You may attempt to modify an existing template using a text editor.  There are a several alternatives:

Option 1: Leveraging Components

1. Create a component with a face that has the SketchUp material using your Custom Template Settings.  i.e. “Water1”  It is 
important that the name for your material you want to use be unique from the default SketchUp Material names, 
otherwise  the imported material will be overwritten by any similarly named material already within the scene. 

2. Create a personal Component Library in the SketchUp/Components folder, and call it something like "Twilight".
3. Save the component “Water1” containing the specialized “Water” material into your “Twilight” components folder.
4. Start a new scene and insert the “Water1” component from your newly created Twilight Library.
5. The material definition is now in your scene.
6. Using the alt key with SketchUp's paint bucket tool you can sample the water from the inserted component, and paint it on other 

surfaces around the scene.
7. Another alternative is to Shift -drag the material from one surface to another using the Twilight Material Eye Dropper Tool.

Option 2: Leveraging .skp Models/Scenes
Save a simple "storage" model somewhere on your hard drive.  Call it "MyTwilightMaterials.skp"

• When you have a material you like in Twilight, copy a face containing the material from your model and paste it into your 
"MyTwilightMaterials.skp" model.

• Then when you need the material, you can open the "MyTwilightMaterials.skp" and copy that face and paste it back into your 
new model, then shift-drag the material onto your current model as described in Option 1 above.
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Option 3: Create a Custom Material Library for the Scene Using Kerkythea 2008 Echo.

1. Export scene to Kerkythea.
2. Open the Material Editor
3. In left pane select and right-click the material(s) and send the Scene's Materials to the right pane
4. Save Material Library / give it a name.
5. Use Twilight's Options>Files&Directories panel to add the new Material Librarie's path location.  You will see the Material 

Library of Kerkythea upon re-opening SketchUp the New Material Library will be listed in the Twilight Material Libraries.
-or-

6. Copy the new Library File from the Kerkythea/Materials/Libraries folder into the Twilight/Materials folder.

DISADVANTAGES TO REMEMBER WHEN USING LIBRARIES:
In the setting of an office or network, when sharing a scene, the library must also be sent with the file.
Library materials are 'dumb' materials, that is, they can not be easily edited. Edge Lines do not work with Library Materials, unless they 
are created specifically to do so.  Materials can of course be exported via .xml to Kerkythea, edited, and saved into a library again, etc. 

Faceted Geometry of Curved Surfaces

If there is a curved surface that should be rendering smooth, but it renders as faceted, place the geometry within a group or component, 
and it should render smooth.

HDR

High Dynamic Range (HDR) images contain 32 bits of information per pixel as opposed to 8 bits with a .jpg.  In rendering one typically 
uses a spherically mapped HDR image to actually project light onto a 3D scene from all directions at once.  In this manner, if an HDR is 
created in a specific place (St. John's Cathedral, for example) and then used to light a 3D object, one should be theoretically able to 
visualize the object as if it were lit with the exact light that it would get in St. John's Cathedral.  There are thousands of HDR images 
available for download via many different websites.

HDR typically provide all the light your scene needs.  Exceptions would be in the case of using HDR images to light an Interior.  It's better 
to not use sun in conjunction with an HDR in the Sky, but for artistic effect this is common practice.  In this case changing (lowering) the 
power of the sun and/or changing the intensity of the sky, and/or lowering the exposure of the rendered image may be advisable.

In Twilight one also has the ability to save an image as an HDR.  In this case, one would do so in order to have the ability to take 
advantage of the darkest and lightest areas of the image, where in a normal image some of these areas may not be able to be seen 
clearly, with an HDR one may tonemap them using a photo editor to get the greatest visual tonal range.  Of course, if the Camera is set to 
Spherical, and the image is saved as HDR, you will have a spherically mapped HDR image of your model.
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IES Data Files (.ies)

IES is a file format developed by IESNA a consortium of illuminant manufacturers and other Agencies. It contains manufacturer data and 
Photometric data that show the light distribution pattern of the illuminant, typically a specific light fixture.  It is typically available from the 
lighting manufacturer's website alongside the other technical information for the light fixture.  Download the .ies format text file and use 
the IES (Photometric) Light Options Tab in The Light Editor Dialog to Browse to the .ies file.  Now the light object will emit light in a way 
that is specifically mimicking the light emmittance for that light fixture.  Be sure the power of the light is set to 1.  To increase the 
brightness of lights, typically adjusting the exposure of the camera on the Camera Tab will do the trick.  If the IES is surprisingly dim for 
some reason, it could be a poor .ies file, or it could be for a fixture with particularly low light output.

Light Portal: see Sky Portal

Light Through A Window:

You are rendering an interior and have sun coming through the window.  Here are a few tips.

• Be sure all windows are only modeled with a single pane of glass.
• Be sure you have applied a material to the glass using SketchUp's materials, such as the typical "translucent_glass_grey" or 

whatever
• Be sure you use the Twilight Material Tool to click that glass material on the windows and apply the Architectural 

Glass>"Common" or "No Shadow"
• Set the sun in SketchUp to cast as much light as possible into your room... the more light the better.
• Apply material templates that are appropriate to your other objects.
• Render a small test render with Easy01-Prelim
• Adjust tone mapping exposure in the camera panel of the Render Window if image is too dark.  (Typically will be too dark, try 

Exposure=1.7)
• When happy with camera, materials, etc. Render test render at 800x600-ish on Low or Medium easy settings.
• When happy and ready for the "final" render on Easy09 progressive. This will give you best results with so little light.
• Perhaps try using a Sky Portal: the Sky Portal Material is for use on models of interiors where they rely on the Sun and Sky.
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Lighting An Interior Scene

First, Build reasonably accurate component for your lights.  Insert a Twilight Light Object inside the Light Component. Put the lights in places and with 
powers that are equivalent to the way the space would be lit in real life.

Avoid fill lights, and fakery unless you know what you are doing... they typically add render time, and detract from the 'real' look of the final image... and 
may actually make the rendering simply 'over lit' and blown out, leading to SLOWER render times.

It's difficult to give a 'wattage' power to a spot light in Twilight. But for a rule of thumb, assume the default spot light is a 100w bulb in Lumen output. 
Lights don't emit "watts", they use Watts to emit light which is measured in "Lumens".

The closer the hotspot number is to the falloff number, the lower the light power will need to be, so a hotspot of 30, falloff of 31 can mimic a 100w bulb 
with a power of only .5 or something like that. For a hotspot of 10 falloff of 179 the power will need to be about 1.5 to mimic the behavior of a 100w 
bulb... just as a very general idea.

For the most accurate lighting with spotlights, insert a spot, set power to "1" and load the IES data for the fixture using the IES tab in the Twilight 
Light Editor. Rendering it in Easy 09 or 10 for interiors will be most accurate.

To calculate the power for light emitter surfaces is a bit more complicated.

Let's say you have a large space and you want to light it all quickly and evenly with just 2 lights. 
We just said above that we don't want to 'fake' lighting, typically, so what are we talking about here? Occasionally you will need to use some 'creative 
lighting' to render quickly yet still look good. So for your average space, just light it as is, but for a huge gymnasium with 200 light sources, there may be 
a better way...anything over 15 lights is considered a "lot" of lights for "Easy" render settings 1-8.

Create a plane below the ceiling. Hold if off from the side walls about a foot (30cm).
Then paint it with white, and rename it “Emit” then apply the Template “Emit 100w/m2”

Select the face in SketchUp and look at the Entity Info to see how many meters squared it is, then go from there to figure out the power you want it to 
emit.  If you want a total emittance of 1000 watts to light the entire space (large dining hall or airplane hangar), and your plane is 5540sqft(515sqmeters) 
and you apply the 100w/m2 light emit template, this will mean that the plane will emit 515m2x100w = 51500watts… 

This is too much, so change that to what you want, and put that amount of watts you want it to emit. 1000w/515m2=1.942 w/m2. So set emitter to 1.942 
w/m2 for a 515 square meter plane to make it mimick the light output of an emitter powered by 1000 total watts.

Now your ceiling just became a 1000watt light bulb and equals 2 lights in Twilight because a rectangle will be triangulated, but because the light is in 
power defined by area, it doesn't matter the number of triangles, but rather the area. 
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Material Priority

In SketchUp there are so many ways you can paint things that there needs to be a priority order for rendering these materials.  When 
painting objects keep in mind these important tips:

1. It is best to paint faces, not groups or components.  It is best to paint Front Faces!  Try not to paint back faces.*
2. If a group or component is painted with a color or texture, the FRONT faces in that component or group will acquire that color.  
3. If a BACK face is painted with a color inside of a group or component, and the Component itself is painted with a different color 

or texture, the Face will render with the color painted on the Component, not the color painted on the back face inside of the 
component.  This is different from how you see the colors displayed in SketchUp's view.

*The Back Face in SketchUp is by default a blue color.  Avoid painting back faces because the normal for a back face will return  the opposite information for materials for a 
bump or specular map than you want it to give.  Also, if a back and front face are painted, the front face's material will be what you will see, not the back.  So this will give 
confusing results in your rendering.  Only paint front faces.

Model Processing Phase

The Model Processing Phase happens just after you click the Start Render Button.  It is the part of the rendering phase when Twilight 
processes all geometry, components, lighting, cameras, materials, and animation information in your scene.  Hidden geometry is not 
processed.  Objects on a layer that has been turned off are not processed.  

You can control what is processed from your scene in many ways:

1 Select an object and tell Twilight to render only that object

1. Select the object you wish to render by itself.
2. Click the Twilight Power Button to open the render dialog.
3. Click the Start Render Button.
4. Twilight will then ask you if you want to render only the selected object(s).
5. Click “Yes”.  This will then cause Twilight to render only the selected object(s).

2 Turn off a layer containing objects you wish to hide.

1. It is wise in SketchUp to draw everything on the default layer (Layer0).  
2. This way if you wish to hide some objects (such as furniture, or Phase 1) you can create a layer (such as one called “Furniture” 

or “Phase 1”).  
3. Then, in SketchUp's Pull-down Menu “View” go to “View>Toolbars>Layers”.  
4. Now selecting an object(s) in your scene you can force that object onto another layer by simply going to the Layers' pull-down 

menu and choosing your layer (such as one called “Furniture””).  
5. Now open the SketchUp Layers dialog via SketchUp's pull-down menu “Window > Layers” and uncheck the box next to the 

layer name holding the objects you wish to hide.  
6. Or simply go to Twilight's Render Window, and choose the pull-down menu “Layers” and deselect the name of the layer you 

wish to hide by clicking the name of the layer.  This will leave it visible in SketchUp's scene view, but not render it.

3 Hide an object or group inside of Google SketchUp.

Select an object and context-click (right-click), choose “Hide”.  Or go to Sketchup's Menu “Edit > Hide”
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4 Nested Groups, Components, or Objects on Hidden Layers

Putting High-polygon objects on hidden layers inside of components allows 
one to hide the layer while work, yet see the object when rendered.  This is 
also known as one way of handling “proxy” objects.  See full description in the 
Reference Section “Proxy Object, or, High Polygon Object Rendering/Handling 
in SketchUp.”

5 In the Advanced Tab you can set the processing to work only on lights and cameras.

Under the Content Updates : Update Method > Lights, Cameras.

If you have not yet already processed the entire scene once it will automatically do so.  After that, each time a rendering is started, it will 
only change the lights and cameras, but the materials/model will be reused from the last rendering.  This speeds processing greatly on 
large scenes after the full model has been processed once and you are working only on modifying lights or cameras and find yourself re-
rendering multiple tests.  When rendering architectural animations where the camera is the only animated object, there is no need to  
change this method on the Advanced Tab, simply choose “ViewOnly” in the Animation Dialog “Type” pull-down.

If you find you have changed geometry or materials, and they are not being updated in the rendered scene, be sure to check if this option 
is enabled.  If so, change it to process “All” once again.

Multithreading and Rendering Machine Recommendations

Twilight will render in Multithread mode on most Windows computers running SketchUp or a virtual Windows set up for Mac users.  

Threads = Number of Threads provided by your processor(s) to employ in rendering the image.  Multithreading means that the computer is 
utilizing more than one Thread to do a task.  Twilight will by default render with the maximum number of threads found on the machine.  

However, computer prices are affordable today with machines available now that have processors that utilize a technology called 
“hyperthreading” that gives them 8 threads.  This means it is affordable to have a machine that renders with high speed using Twilight on 
8 threads at a surprisingly low cost.  This same technology even makes each thread faster than one may expect.  It is suggested for 
maximum enjoyment of Twilight that one do research before purchasing a machine for rendering.  Affordable machines are now 
commercially available with 16 threads.

Post-processing (aka Post-Pro, or PP)

Post-processing is the action of editing any raw image after it has been rendered by a render engine (such as Twilight).  Editing the 
image can be done with any number of photo/image editing programs such as the free program known as The Gimp, or the well-known 
Photoshop.  To learn more about methods of Post-pro, simply search the internet for tutorials on the subject of interest.  Twilight Render 
provides several hi-quality Post-pro technique tutorials on its forum.
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Proper Animation for SketchUp by Morisdov (+ Mover.rb Animation Plugin for SketchUp)

This is an animation plugin for SketchUp that allows one to animate objects, such as the opening of doors, or moving of an object from 
one place to another.  When used properly, it's animations will be automatically rendered by Twilight.  Set up the Animation Options 
appropriately as described in the Animation Tab section of this manual.  Mover.rb provided by CMD of the Google SketchUp Team is even 
easier to use and very handy for Animating objects within SketchUp for rendering with Twilight.  Jim Folz has developed it further here 
with dialogs and easings.

Proxy Object, or, High Polygon Object Rendering/Handling in SketchUp

As of Twilight version 1.1 
SketchUp's layers are 
handled on a WYSIWYG 
(What you see is what you 
get) basis.  So any layer you 
see turned on in your 
SketchUp Scene should also 
be what is rendered in 
Twilight, and vice-versa.

Proxy Rendering is available 
in Twilight by leveraging the 
power of Layer Visibility in 
SketchUp.  A “Proxy” is a 
“Stand In” for something else. 
A Proxy object in SketchUp is 
something you can see that 
represents “stands in for” 
something much more 
complex.

Try this workflow for working with High Polygon models that will be used more than once in your model, or with any model that will be 
used many times and slow down your work in SketchUp.

1. Geometry should be drawn on Layer 0, then select the geometry and turn it into a component.
2. That component should be placed on a unique layer called something such as “High Poly Object Layer”.  
3. Now Create a bounding box around that High poly component and erase the faces so that there are only edge lines.
4. Turn the edge lines into a component and place that component on a unique layer called something like “High Poly Guidelines”
5. Select the two components and create a new component called “My Combined Component on Layer 0.
6. Now turn visibility OFF for the layer “High Poly Object Layer” using SketchUp's Layer Dialog Visibility Check Box. (Do NOT hide 

the geometry, it will NOT render!)
7. Then, select the component, one may choose “Render all Layers in Component” from the Right-click>Twilight Context Menu.
8. After changing a component to have it's layers rendered whether or not they are visible, you can set it back to “normal” by 

choosing the component again, Right-Click, then choose Twilight> Render only visible Layers in Component 

Note that if there is a smaller component located inside the larger component (known as a “nested” component), this choice must be 
deliberately activated upon all nested componets.  If you have enabled the “Render all Layers in Component” option for a component, yet 
something on the same layer within the component will not render, be sure to check if that object is inside of a nested component.
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Reflection Maps (Specular Map)

Using a Reflection Map or “Specular” Map one can precisely control the 
amount of light reflected.  Related to Alpha Mask, or Bump Maps, the 
Reflection Map reacts so: 

Black = No Reflection, 

Gray = Percentage of Reflection

White = Perfect Reflection

Combining a good reflection map with a good Bump Map will make 
extremely photo-realistic materials.

To assign a Reflection Map in Twilight after assigning a Template:

1. Choose “Texture” under “Reflection” Material slot.

2. Browse to and load the reflection map texture.

RGB (Red Green Blue)

RGB are the Red Green and Blue values (numbers) used in order for a 
color to be displayed on a computer screen.  An RGB value is written as: 
rgb(251, 190, 36) in Twilight dialogs.  Other related ways to modify a color 
in SketchUp's material dialog are by using the Color Wheel, HLS (Hue, 
Lightness, Saturation) and HSB (Hue, Saturation, Brightness).

For those experienced with rendering, and desiring more than Specular 
Reflection control via a “true” Reflection map, this is available in Twilight via 
Kerkythea Materials.  Refer to the Twilight Render Tips, Tricks and More 
Forum for tutorials, including a video tutorial showing how to leverage 
Twilight with Kerkythea's Material Editor.
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